Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Latest Releases

Assassins Creed III Remastered [Day One Patch + All DLCs + MULTi13] 9.1GB - CorePack V1 | AVAILABLE!

Borderlands - Game of the Year Enhanced Edition [MULTi6] - From 5.8 GB | AVAILABLE!

Borderlands : The Pre-Sequel - Remastered [7 DLCs + MULTi8] - From 7.5 GB | AVAILABLE!

Ni no Kuni™ II: REVENANT KINGDOM - The Tale of a Timeless Tome [v4.0 + 7 DLCs + MULTi7]

South Park: The Fractured But Whole  Gold Edition

World War Z [MULTi10] - 15.1 GB | AVAILABLE !

      • 0
      Sign in to follow this  
      fziert

      Game Lag

      Question

      fziert
      Posted (edited)

      Hi,

       

      i installed Sekiro: Shadows Die Twice game but it lags too much from the start.

      I am playing  in  a laptop connected with ac power:

      specs          i7 8th gen(8750H),6 gb 1060 gfx,16gb ram 

      Edited by fziert
      • Like 1
      • Confused 1
      • Sad 1

      Share this post


      Link to post
      Share on other sites

      7 answers to this question

      Recommended Posts

      • 4
      BedBug

      well that is a good specs u got according to specs it should not lag

      cuz i m playing it in i5-6th gen,8gb ram, 4gb 940mx at high settings and everything seems to be f9 except here and there

      • Like 3

      Share this post


      Link to post
      Share on other sites
      • 4
      SpiritualMage
      Posted (edited)

      The game is working fine on my laptop, no issues.

      I've  i5-7300HQ, GTX1060 6GB, 8GB RAM.

      Try the game on High Performance mode from power option, maybe it could help you.

      910210050_Annotation2019-04-07124712.png.432653db1831e62a86c121dab7f03e7d.png

      Or maybe some sought of program is running in the background eating up you RAM !

      Or try disabling Shadow Play from Nvidia Geforce Experience.

      Edited by SpiritualMage
      • Like 4

      Share this post


      Link to post
      Share on other sites
      • 3
      ~Os~

      Update your Drivers

      • Like 2

      Share this post


      Link to post
      Share on other sites
      • 2
      -PHASOS-

      Open Nvidia control panel/3d settings/programs

      Add the exe of the game and select high performance Nvidia processor

      • Like 1

      Share this post


      Link to post
      Share on other sites
      • 0
      fziert
      1 minute ago, BedBug said:

      well that is a good specs u got according to specs it should not lag

      cuz i m playing it in i5-6th gen,8gb ram, 4gb 940mx at high settings and everything seems to be f9 except here and there

      is there any update after that?

      • Like 1

      Share this post


      Link to post
      Share on other sites
      • 0
      fziert
      1 hour ago, SpiritualMage said:

      The game is working fine on my laptop, no issues.

      I've  i5-7300HQ, GTX1060 6GB, 8GB RAM.

      Try the game on High Performance mode from power option, maybe it could help you.

      910210050_Annotation2019-04-07124712.png.432653db1831e62a86c121dab7f03e7d.png

      Or maybe some sought of program is running in the background eating up you RAM !

      Or try disabling Shadow Play from Nvidia Geforce Experience.

      okk..thanx for suggestions ...i ll try that

      • Like 2

      Share this post


      Link to post
      Share on other sites

      Join the conversation

      You can post now and register later. If you have an account, sign in now to post with your account.

      Guest
      Answer this question...

      ×   Pasted as rich text.   Restore formatting

        Only 75 emoji are allowed.

      ×   Your link has been automatically embedded.   Display as a link instead

      ×   Your previous content has been restored.   Clear editor

      ×   You cannot paste images directly. Upload or insert images from URL.

      Sign in to follow this  

      ×
      ×
      • Create New...